Degraded e-mail delivery performance
Incident Report for Signhost Verified Signing
Resolved
Office mail service problems seem resolved by Sparkpost. If you are still encountering delivery problems, you can put noreply@signhost.com on your allowlist.
Posted Feb 27, 2024 - 13:27 CET
Identified
Some customers continue to report (1) messages are going to the junk/spam folder, and, (2) an elevated number of opens and clicks from Office 365 addresses.

We are aware of this and are in discussions with the party sending our mails and Microsoft to resolve this. In the meantime, we would like to advise you to place our mail domain (noreply@signhost.com) or your configured sending domain on your allowlist and register it as a safe sender.
Posted Feb 16, 2024 - 13:27 CET
This incident affected: External services (Mail service).