DOWN - Major Incident Notification - itsme® Services
Incident Report for Evidos trust services
Resolved
Itsme has resolved this issue.
Posted May 06, 2020 - 16:44 CEST
Update
Itsme is still investigating this problem, and will keep us posted. We will update this page if we receive updates from itsme.
Posted May 06, 2020 - 15:20 CEST
Investigating
Itsme is currently experiencing delays and slowness. This is being investigated on itsme's end.
Posted May 06, 2020 - 12:44 CEST
This incident affected: ⮑ External verifications (itsme).