itsme® services and environments are currently down
Incident Report for Evidos signing services
Resolved
This incident has been resolved.
Posted 3 months ago. May 16, 2019 - 16:28 CEST
Investigating
The itsme verification is currently unavailable and is under investigation by itsme.
Posted 3 months ago. May 15, 2019 - 22:00 CEST
This incident affected: ⮑ External verifications (itsme).